NDDR and CDCS System Availability

Incident Report for NDDR and CDCS

Resolved

System metrics show NDDR and CDCS is back operating within expected range. Please raise a support request if you have any further issues connecting to the system.
Posted Oct 29, 2025 - 18:44 CDT

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 16:20 CDT

Monitoring

Services are confirmed back online in some locales. System speeds may be slow as the recovery continues, but the systems are at least partially accessible once again.
Posted Oct 29, 2025 - 15:32 CDT

Update

Recovery is proceeding, although it may be uneven given the nature of the network services impacted. This means you may see some centers have the ability to access the system while others remain offline.

The current ETA for full recovery is 23:20 UTC -- approximately 3 hours from now.
Posted Oct 29, 2025 - 15:08 CDT

Update

We are seeing signs of initial recovery from the upstream network and DNS provider, but the restoration process is ongoing.
Posted Oct 29, 2025 - 13:36 CDT

Update

A fix has been identified and is being applied, although there is no ETA for final resolution. We will update again as soon as we have new information.
Posted Oct 29, 2025 - 12:21 CDT

Identified

NDDR and CDCS is currently impacted by the global DNS outage affecting Microsoft services.

We are investigating a workaround and will communicate new updates as we progress.
Posted Oct 29, 2025 - 11:49 CDT

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 11:09 CDT

Investigating

We are currently investigating an issue with the availability of NDDR and CDCS services
Posted Oct 29, 2025 - 10:59 CDT
This incident affected: Web (Web) and API (API Endpoints, API Tokens).